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 13 Working with Other 
  Microsoft Office  
  Programs

In this chapter, you will learn how to
✔ Include Office documents in workbooks.
✔ Store workbooks as parts of other Office documents.
✔ Create hyperlinks.
✔ Paste charts into other documents.

By itself, Microsoft Excel 2010 provides a broad range of tools so that you can store, 
present, and summarize your financial data. When you use other Microsoft Office 2010 
programs, you can extend your capabilities even further, creating databases, presenta-
tions, written reports, and custom Web pages through which you can organize and 
communicate your data in print and over networks.

All the Office programs interact with each other in many useful ways. For example, you 
can include a file created with another Office program in an Excel workbook. If you use 
Microsoft Word 2010 to write a quick note about why a customer’s shipping expenditures 
decreased significantly in January, you can include the report in your workbook. Similarly, 
you can include your Excel workbooks in documents created with other Office programs.  
If you want to copy only part of a workbook, such as a chart, to another Office docu-
ment, you can do that as well.

Excel integrates well with the Web. If you know of a Web-based resource that would be 
useful to someone who is viewing a document, you can create a hyperlink, or connection 
from a document to a place in the same file or to another file anywhere on a network or 
the Internet that the user’s computer can reach. 
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In this chapter, you will learn how to include an Office 2010 document in a worksheet, 
store an Excel workbook as part of another Office document, create hyperlinks, and paste 
an Excel chart into another document.

Practice Files Before you can complete the exercises in this chapter, you need to copy 
the book’s practice files to your computer. The practice files you’ll use to complete the 
exercises in this chapter are in the Chapter13 practice file folder. A complete list of 
practice files is provided in “Using the Practice Files” at the beginning of this book.

Including Office Documents in Workbooks
One benefit of working with Excel 2010 is that because it is part of Office 2010, it is 
possible to combine data from Excel and other Office programs to create informative 
documents and presentations. Just as you do when you combine data from more than 
one Excel document, when you combine information from another Office file with an 
Excel workbook, you can either paste the other Office document into the Excel work-
book or create a link between the workbook and the other document.

There are two advantages to creating a link between your Excel workbook and the 
other file. The first benefit is that linking to the other file, as opposed to copying the 
entire file into your workbook, keeps your Excel workbook small. If the workbook is 
copied to another drive or computer, you can maintain the link by copying the linked 
file along with the Excel workbook or by re-creating the link if the linked file is on the 
same network as the Excel workbook. It is also possible to use the workbook if the linked 
file isn’t available. The second benefit of linking to another file is that any changes in 
the file to which you link are reflected in your Excel workbook.

You create a link between an Excel workbook and another Office document by clicking 
the cell where you want the document to appear, clicking the Insert tab and then, in the 
Text group, clicking Object to display the Object dialog box. In the Object dialog box, 
click the Create From File tab.
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Clicking the Browse button on the Create From File page opens the Browse dialog box, 
from which you can browse to the folder containing the file you want to link to. After 
you locate the file, double-clicking it closes the Browse dialog box and adds the file’s 
name and path to the File Name box of the Object dialog box. To create a link to the 
file, select the Link To File check box, and click OK. When you do, the file appears in 
your workbook near the active cell.

If you want to link a file to your workbook but don’t want the file image to take up much 
space on the screen, you can also select the Display As Icon check box. After you select 
the file and click OK, the file will be represented by the same icon used to represent it in 
Windows. Double-clicking the icon displays the file.
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After you have linked a file—for example, a Microsoft PowerPoint 2010 presentation—to 
your Excel workbook, you can edit the file by right-clicking its image or icon in your work-
book and then, on the shortcut menu that appears, pointing to the appropriate Object 
command and clicking Edit. For a PowerPoint file, you point to Presentation Object. The 
file will open in its native application. When you finish editing the file, your changes 
appear in your workbook.

Tip The specific menu item you point to changes to reflect the program used to create the 
file to which you want to link. For a Word 2010 document, for example, the menu item you 
point to is Document Object.

In this exercise, you’ll link a PowerPoint 2010 presentation showing a business summary 
to an Excel workbook and then edit the presentation from within Excel. 

Important You must have PowerPoint 2010 installed on your computer to complete this 
exercise.

SET UP You need the SummaryPresentation_start workbook and 
the 2010YearlyRevenueSummary_start presentation located in your 
Chapter13 practice file folder to complete this exercise. Start Excel, open the 
SummaryPresentation_start workbook, and save it as SummaryPresentation. 
Then start PowerPoint, open the 2010YearlyRevenueSummary_start presentation,  
and save it as 2010YearlyRevenueSummary. Close PowerPoint, and then follow 
the steps. 

 1. In the SummaryPresentation workbook, on the Insert tab, in the Text group, 
click Object.

The Object dialog box opens.

 2. Click the Create from File tab.

The Create From File page is displayed.

 3. Click Browse.

The Browse dialog box opens.
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 4. Browse to the 2010YearlyRevenueSummary.pptx presentation, and then click 
Insert.

The Browse dialog box closes, and the full file path of the 
2010YearlyRevenueSummary presentation appears in the File Name box.

 5. Select the Link to file check box, and then click OK.

Excel creates a link from your workbook to the presentation.

 6. Right-click the presentation, point to Presentation Object, and then click Edit.

The presentation opens in a PowerPoint 2010 window.
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Troubleshooting The appearance of buttons and groups on the ribbon changes depending 
on the width of the program window. For information about changing the appearance of 
the ribbon to match our screen images, see “Modifying the Display of the Ribbon” at the 
beginning of this book.

 7. Click Consolidated Messenger FY2010.

The text box containing Consolidated Messenger FY2010 is activated.

 8. Select the FY2010 text, and then type Calendar Year 2010.

 9. In PowerPoint, on the Quick Access Toolbar, click the Save button.

PowerPoint saves your changes, and Excel updates the linked object’s appearance 
to reflect the new text.

 10. Click the File tab, and then click Save.

CLEAN UP Close the SummaryPresentation workbook and the 
2010YearlyRevenueSummary presentation. If you don’t plan to  
work through the next exercise immediately, exit PowerPoint.
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Storing Workbooks as Parts of Other  
Office Documents

In the preceding section, you linked to another file from within your Excel workbook. The 
advantages of linking to a second file are that the size of your workbook is kept small and 
any changes in the second document will be reflected in your workbook.  The disadvan-
tage is that the second document must be copied with the workbook—or at least be on 
a network-accessible computer. If Excel can’t find or access the second file where the link 
says it is located, Excel can’t display it. You can still open your workbook, but you won’t see 
the linked file’s contents.

If file size isn’t an issue and you want to ensure that the second document is always 
available, you can embed the file in your workbook. Embedding another file in an Excel 
workbook means that the entirety of the other file is saved as part of your workbook. 
Wherever your workbook goes, the embedded file goes along with it. Of course, the 
embedded version of the file is no longer connected to the original file, so changes in 
one aren’t reflected in the other.

Important To view a linked or embedded file, you must have the program used to create it 
installed on the computer on which you open the workbook.

You can embed a file in an Excel workbook by following the procedure described in the 
preceding section but leaving the Link To File check box cleared.

It is also possible to embed your Excel workbooks in other Office documents. In PowerPoint, 
for example, you can embed an Excel file in a presentation by displaying the Insert tab in 
PowerPoint and then, in the Text group, clicking Object to display the Insert Object dialog 
box. Then in the Insert Object dialog box, select Create From File.
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To identify the file you want to embed, click the Browse button and then, in the Browse 
dialog box that opens, navigate to the folder where the file is stored and double-click 
the file. The Browse dialog box closes, and the file path appears in the File box. Click OK 
to embed your workbook in the presentation.

If you want to  embed a workbook in a file created with any other Office program but 
don’t want the worksheet to take up much space on the screen, select the Display As 
Icon check box. After you select the file to embed and click OK, the file is represented  
by the same icon used to represent it in Windows. Double-clicking the icon opens 
the embedded document in its original application.

Troubleshooting If your Excel workbook’s cells don’t have a background fill color (that is, 
you have the No Fill option selected), PowerPoint treats the cells’ backgrounds as if they 
were transparent. If you were to place cells with black text and no background fill over a 
dark background, you would not be able to see the text. To make your text visible, fill the 
cells with a very light gray color so the presentation’s background doesn’t show through.

To edit an embedded Excel workbook, right-click the workbook (or the icon representing 
it) and then, on the shortcut menu that appears, point to Worksheet Object and click Edit. 
The workbook opens for editing. After you finish making your changes, you can click 
anywhere outside the workbook to return to the presentation.

In this exercise, you’ll embed an Excel workbook containing sales data in a PowerPoint 
presentation.

Important You must have PowerPoint 2010 installed on your computer to complete this 
exercise.

SET UP You need the 2010YearlyRevenueSummary presentation you created in the 
previous exercise, and the RevenueByServiceLevel_start workbook located in your 
Chapter13 practice file folder to complete this exercise. If you did not complete the 
previous exercise, you should do so now. Open the RevenueByServiceLevel_start 
workbook, and save it as RevenueByServiceLevel. Then, if necessary open the 
2010YearlyRevenueSummary presentation. Then follow the steps. 

 1. In the Slides panel of the presentation window, click the second slide.

The second slide appears.

 2. On the Insert tab, in the Text group, click Object.

The Insert Object dialog box opens.
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 3. Select Create from file.

The Insert Object dialog box changes to allow you to enter a file name.

 4. Click Browse.

The Browse dialog box opens.

 5. Browse to the RevenueByServiceLevel workbook and double-click it.

The Browse dialog box closes, and the file’s full path appears in the File box.

 6. Click OK.

The workbook appears in your presentation.

CLEAN UP Save the RevenueByServiceLevel workbook and the 
2010YearlyRevenueSummary presentation, and then close those files.  
Exit PowerPoint.



358  Chapter 13 Working with Other Microsoft Office Programs

Creating Hyperlinks
One of the characteristics of the Web is that documents published on Web pages can have 
references, or hyperlinks, to locations in the same document or to other Web documents. A 
hyperlink functions much like a link between two cells or between two files, but hyperlinks 
can reach any computer on the Web, not just those on a corporate network. Hyperlinks that 
haven’t been clicked usually appear as underlined blue text, and hyperlinks that have been 
followed appear as underlined purple text, but those settings can be changed.

To create a hyperlink, click the cell in which you want to insert the hyperlink and then, 
on the Insert tab, click Hyperlink. The Insert Hyperlink dialog box opens.

Keyboard Shortcut You can also open the Insert Hyperlink dialog box by pressing Ctrl+K. 

See Also For more information about keyboard shortcuts, see “Keyboard Shortcuts” at the 
end of this book.
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You can choose one of four types of targets, or destinations, for your hyperlink: an existing 
file or Web page, a place in the current document, a new document you create on the spot, 
or an e-mail address. By default, the Insert Hyperlink dialog box displays the tools to 
connect to an existing file or Web page.

To create a hyperlink to another file or Web page, you can use the Look In navigation tool 
to locate the file. If you recently opened the file or Web page to which you want to link, 
you can click either the Browsed Pages or the Recent Files button to display the Web pages 
or files in your History list.

If you want to create a hyperlink to another place in the current Excel workbook, you 
can click the Place In This Document button to display a list of available targets in the 
current workbook.
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To select the worksheet to which you want to refer, you click the worksheet name in the 
Or Select A Place In This Document box. When you do, a reference with the name of 
the worksheet and cell A1 on that worksheet appears in the Text To Display box.

If you want to refer to a cell other than A1 on the selected worksheet, click the worksheet 
name in the Or Select A Place In This Document box, and then change the cell reference 
in the Type The Cell Reference box.

You can also create a hyperlink that generates an e-mail message to an address of your 
choice. To create this type of hyperlink, which is called a mailto hyperlink, click the E-mail 
Address button.
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In the dialog box that opens, you can type the recipient’s e-mail address in the E-mail 
Address box and the subject line for messages sent via this hyperlink in the Subject box.

Tip If you use Windows Mail, Microsoft Outlook, or Microsoft Outlook Express as your 
e-mail program, a list of recently used addresses will appear in the Recently Used E-Mail 
Addresses box. You can insert any of those addresses in the E-mail Address box by clicking 
the address.

Clicking a mailto hyperlink causes the user’s default e-mail program to open and create 
a new e-mail message. The e-mail message is addressed to the address you entered in 
the E-mail Address box, and the subject is set to the text you typed in the Subject box.

Regardless of the type of hyperlink you create, you can specify the text you want to 
represent the hyperlink in your worksheet. You type that text in the Text To Display 
box. When you click OK, the text you type there appears in your worksheet, formatted  
as a hyperlink.

Tip If you leave the Text To Display box empty, the actual link will appear in your worksheet.

To edit an existing hyperlink, click the cell containing the hyperlink and then, on the 
shortcut menu that appears, click Edit Hyperlink. You can also click Open Hyperlink to 
go to the target document or create a new e-mail message, or click Remove Hyperlink 
to delete the hyperlink.

Tip If you delete a hyperlink from a cell, the text from the Text To Display box remains in the 
cell, but it no longer functions as a hyperlink.

In this exercise, you’ll create a hyperlink to another document and then a second hyperlink 
to a different location in the current workbook.

SET UP You need the Hyperlink_start and LevelDescriptions_start workbooks located in 
your Chapter13 practice file folder to complete this exercise. Open the Hyperlink_start 
workbook and save it as Hyperlink, and then open the LevelDescriptions_start workbook 
and save it as LevelDescriptions. Then follow the steps. 

 1. In the Hyperlink workbook, on the Revenue by Level worksheet, click cell B9.

 2. On  the Insert tab, in the Links group, click the Hyperlink button.

The Insert Hyperlink dialog box opens.

 3. If necessary, click the Existing File or Web Page button.
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 4. If necessary, use the controls to the right of the Look in box to navigate to the 
Chapter13 practice file folder.

The files in the target folder appear in the Insert Hyperlink dialog box.

 5. In the file list, click the LevelDescriptions workbook, and then click OK.

The workbook’s full path appears in the Text To Display box and the Address box.

 6. In the Text to display box, edit the value so that it reads LevelDescriptions.

 7. Click OK.

 8. Click the hyperlink in cell B9.

The LevelDescriptions workbook appears.

 9. In the LevelDescriptions workbook, click the File tab, and then click Close.

The LevelDescriptions workbook closes.

 10. Right-click cell B11, and then click Hyperlink.

The Insert Hyperlink dialog box opens.

 11. In the Link to pane, click Place in This Document.

The document elements to which you can link appear in the dialog box.
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 12. In the Or select a place in this document pane, click Notes.

 13. Click OK.

The Insert Hyperlink dialog box closes, and Excel creates a hyperlink in cell B11.

 14. Right-click cell B11, and then click Edit Hyperlink.

The Edit Hyperlink dialog box opens.

 15. Edit the Text to display box’s value so it reads Revenue Notes.

 16. Click OK.

The Edit Hyperlink dialog box closes, and the text in cell B11 changes to Revenue 
Notes.

 17. On the Quick Access Toolbar, click the Save button to save your work.

CLEAN UP Close the Hyperlink and LevelDescriptions workbooks.
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Pasting Charts into Other Documents
One more way to include objects from one workbook in another Office document is to 
copy the object you want to share and then paste it into its new location. You can copy 
Excel charts to Word documents and PowerPoint presentations to reuse your data with-
out inserting a worksheet into the file and re-creating your chart in that new location. 

When you want to copy the current appearance of the chart to another document 
without creating a link back to the chart, you right-click the chart and click Copy on the 
shortcut menu that appears to copy the chart to the Microsoft Office Clipboard. Then, in 
the document into which you want to paste the chart’s image, on the Home tab of the 
ribbon, in the Clipboard group, click the Paste button’s arrow to display the palette of 
paste options available. The last option on the right, Picture, pastes an image of the 
chart in its current state.

In this exercise, you’ll copy a chart containing sales information to the Clipboard and 
paste an image of the chart into a PowerPoint presentation.

Important You must have PowerPoint installed on your computer to complete this exercise.

SET UP You need the RevenueChart_start workbook and the RevenueSummary_start 
presentation located in your Chapter13 practice file folder to complete this exercise. 
Open the RevenueChart_start workbook and save it as RevenueChart. Then open the 
RevenueSummary_start presentation and save it as RevenueSummary. Then follow 
the steps. 

 1. In the RevenueChart workbook, right-click the chart, and then click Copy.

Excel copies the chart to the Clipboard.

 2. Display the RevenueSummary presentation, which contains a single, blank slide.

 3. Right-click a blank spot in the visible slide, and then, in the Paste Options area of 
the shortcut menu, click the Picture icon.

The chart appears as a static image.
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CLEAN UP Save the RevenueChart workbook and the RevenueSummary presentation, 
and exit PowerPoint. If you are not continuing directly to the next chapter, exit Excel.

Key Points
● Excel is a versatile program. You can exchange data between Excel and other Office 

programs in just a few steps.

● One benefit of Excel is that, because it is part of Microsoft Office 2010, you can 
embed Excel worksheets in other Office documents and embed other Office 
documents (such as PowerPoint presentations) in Excel workbooks.

● Excel works smoothly with the Web; adding hyperlinks to Web pages, other docu-
ments, or specific locations in the current workbook is possible through the Insert 
Hyperlink dialog box.

● After you create a hyperlink, you can edit it to reflect changes in the target site’s 
design and layout. 

● Excel is the easiest Microsoft Office system program in which to create charts. After 
you create a chart in Excel, you can paste it directly into another Office document.
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