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	 7	 Combining Data 
		  from Multiple  
		  Sources
In this chapter, you will learn how to
✔	 Use workbooks as templates for other workbooks.
✔	 Link to data in other worksheets and workbooks.
✔	 Consolidate multiple sets of data into a single workbook.
✔	 Group multiple sets of data.

Microsoft Excel 2010 gives you a wide range of tools with which to format, summarize, 
and present your data. After you have created a workbook to hold data about a particu-
lar subject, you can create as many worksheets as you need to make that data easier to 
find within your workbook. For example, you can create a workbook to store sales data 
for a year, with each worksheet representing a month in that year. To ensure that every 
year’s workbook has a similar appearance, you can create a workbook with the desired 
characteristics (such as more than the standard number of worksheets, custom worksheet 
formatting, or a particular color for the workbook’s sheet tabs) and save it as a pattern, 
or template, for similar workbooks you will create in the future. The benefit of ensuring 
that all your sales data worksheets have the same layout is that you and your colleagues 
immediately know where to look for specific totals. You can use that knowledge to sum-
marize, or consolidate, that data into a single worksheet.

If you work with the same set of workbooks repeatedly, you can group those workbooks 
in a special type of Excel file called a workspace. When you open the workspace, Excel 
knows to open the files you included in that workspace.

	 Contents

	 7	 Combining Data 
		
from Multiple  
		
Sources	 167

Using Workbooks as Templates for Other Workbooks  . . . . . . . . . . . . . . . . . . . . . . .                       168
Linking to Data in Other Worksheets and Workbooks  . . . . . . . . . . . . . . . . . . . . . . .                        175
Consolidating Multiple Sets of Data into a Single Workbook . . . . . . . . . . . . . . . . . .                  180
Grouping Multiple Sets of Data . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .                                           184
Key Points  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .                                                             187



168    Chapter 7  Combining Data from Multiple Sources

A consequence of organizing your data into different workbooks and worksheets is that 
you need ways to manage, combine, and summarize data from more than one Excel 
document. You can always copy data from one worksheet to another, but if the original 
value were to change, that change would not be reflected in the cell range to which you 
copied the data. Rather than remembering which cells you need to update when a value 
changes, you can create a link to the original cell. That way, Excel will update the value for 
you whenever you open the workbook. If multiple worksheets hold related values, you can 
use links to summarize those values in a single worksheet.

In this chapter, you’ll learn how to use a workbook as a template for other workbooks, 
work with more than one set of data, link to data in other workbooks, summarize 
multiple sets of data, and group multiple workbooks.

Practice Files  Before you can complete the exercises in this chapter, you need to copy 
the book’s practice files to your computer. The practice files you’ll use to complete the 
exercises in this chapter are in the Chapter07 practice file folder. A complete list of 
practice files is provided in “Using the Practice Files” at the beginning of this book.

Using Workbooks as Templates for Other 
Workbooks

After you decide on the type of data you want to store in a workbook and what that work-
book should look like, you probably want to be able to create similar workbooks without 
adding all of the formatting and formulas again. For example, you might have established 
a design for your monthly sales-tracking workbook.

When you have settled on a design for your workbooks, you can save one of the work-
books as a template for similar workbooks you will create in the future. You can leave 
the workbook’s labels to aid data entry, but you should remove any existing data from 
a workbook that you save as a template, both to avoid data entry errors and to remove 
any confusion as to whether the workbook is a template. You can also remove any work-
sheets you and your colleagues won’t need by right-clicking the tab of an unneeded 
worksheet and, on the shortcut menu that appears, clicking Delete.

If you want your template workbook to have more than the standard number of work-
sheets (such as 12 worksheets to track shipments for a year, by month), you can add 
worksheets by clicking the Insert Worksheet button that appears to the right of the 
existing worksheet tabs.



To create a template from an existing workbook, save the model workbook as an Excel 
template file (a file with an .xltx extension), which is a file format you can choose from the 
Save As Type list in the Save As dialog box. If you ever want to change the template, you 
can open it like a standard workbook and make your changes. When you have completed 
your work, save the file by clicking the Save button on the Quick Access Toolbar—it will 
still be a template.

Tip  You can also save your Excel 2010 workbook either as an Excel 97–2003 template (.xlt) or 
as a macro-enabled Excel 2010 workbook template (.xltm). For information on using macros in 
Excel 2010 workbooks, see “Introducing Macros” in Chapter 12, “Automating Repetitive Tasks 
by Using Macros.”

After you save a workbook as a template, you can use it as a model for new workbooks. 
To create a workbook from a template in Excel, click the File tab to display the Backstage 
view, and then click New.

When you click New in the Backstage view, the top of the middle pane displays the blank 
workbook template, templates you have used recently, sample templates, and templates 
you created. Below that list is a set of template categories available through the Office.com 
Web site and a search box you can use to locate helpful templates on Office.com.
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Tip  When you display the New page of the Backstage view, you can also find templates and 
other tools related to your job functions by clicking the More Templates folder at the bottom 
of the Office.com Templates area of the page.

From the list of available templates, you can double-click the template you want to use 
as the model for your workbook. Excel creates a new workbook (an .xlsx workbook file, 
not an .xlst template file) with the template’s formatting and contents in place.

In addition to creating a workbook template, you can create a template to add as a work-
sheet within an existing workbook. To create a worksheet template, design the worksheet 
you want to use as a template, delete all the other worksheets in that workbook, and save 
the single-sheet workbook as a template. You can then add a worksheet based on that 
template to your workbook by right-clicking a sheet tab and then clicking Insert to display 
the Insert dialog box.

The Insert dialog box splits its contents into two pages. The General page contains icons 
you can click to insert a blank worksheet, a chart sheet, and any worksheet templates you 
have created. 

Tip  The other two options on the General page, MS Excel 4.0 Macro and MS Excel 5.0 Dialog, 
are there to help users integrate older Excel spreadsheet solutions into Excel 2010.

The Spreadsheet Solutions page contains a set of useful templates for a variety of financial 
and personal tasks.



To add a spreadsheet from the Insert dialog box to your workbook, click the desired 
template, and then click OK. When you click a template, a preview of that template’s 
contents appears in the preview pane, so you can verify you’ve selected the template 
you want.

In this exercise, you’ll create a workbook from an existing template, save a template 
to track hourly call volumes to each regional center, save another version of the file 
as a worksheet template, and insert a worksheet based on that template into a new 
workbook.

SET UP  You need the DailyCallSummary_start workbook located in your 
Chapter07 practice file folder to complete this exercise. Start Excel, open  
the DailyCallSummary_start workbook, and save it as DailyCallSummary. 
Then follow the steps. 

	 1.	 Click the File tab, and then click Save As.

The Save As dialog box opens.

	 2.	 In the Save as type list, click Excel Template.

Excel displays the default Microsoft Office template folder.
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	 3.	 Click Save.

Excel saves the workbook as a template and closes the Save As dialog box.

	 4.	 Click the File tab, and then click Close.

Excel closes the DailyCallSummary workbook.

	 5.	 Click the File tab, and then click New.

The New Workbook dialog box opens.

	 6.	 In the Available Templates list, click Sample Templates.

The Sample Templates gallery appears.

	 7.	 Click Expense Report, and then click Create.

Excel creates a workbook based on the selected template.



Troubleshooting  The appearance of buttons and groups on the ribbon changes depending 
on the width of the program window. For information about changing the appearance of 
the ribbon to match our screen images, see “Modifying the Display of the Ribbon” at the 
beginning of this book.

	 8.	 On the Quick Access Toolbar, click the Save button.

The Save As dialog box opens.

	 9.	 In the File name box, type ExpenseReport. Use the dialog box controls to browse 
to the Chapter07 folder, and then click Save.

Excel saves your workbook.

	 10.	 Click the File tab to display the Backstage view, click Recent, and then, in the Recent 
Workbooks list, click the DailyCallSummary workbook file (not the template).

The DailyCallSummary file is displayed.
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	 11.	 Right-click the Sheet2 sheet tab, and then click Delete.

Excel deletes the worksheet, leaving one worksheet in the workbook.

	 12.	 Click the File tab, and then click Save As.

The Save As dialog box opens.

	 13.	 In the File name box, type DailyCallWorksheet.

	 14.	 If necessary, in the Save as type list, click Excel Template.

	 15.	 Click Save.

Excel saves your template.

	 16.	 Click the File tab, and then click Close.

Excel closes the template.

	 17.	 Click the File tab, and then click New.

The New Workbook dialog box opens.

	 18.	 Click Blank Workbook, and then click Create.

A blank workbook is displayed.

	 19.	 Right-click any sheet tab, and then click Insert.

The Insert dialog box opens.



	 20.	 On the General page, click DailyCallWorksheet, and then click OK.

Excel creates a new worksheet based on the template.

	 21.	 On the Quick Access Toolbar, click the Save button.

The Save As dialog box opens.

	 22.	 In the File name box, type CurrentCallSummary. Use the dialog box controls to 
browse to the Chapter07 folder, and then click Save.

Excel saves your workbook.

CLEAN UP  Close the CurrentCallSummary workbook.

Linking to Data in Other Worksheets and 
Workbooks

Copying and pasting data from one workbook to another is a quick and easy way to gather 
related data in one place, but there is a substantial limitation: If the data from the original 
cell changes, the change is not reflected in the cell to which the data was copied. In other 
words, copying and pasting a cell’s contents doesn’t create a relationship between the 
original cell and the target cell.
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You can ensure that the data in the target cell reflects any changes in the original cell by 
creating a link between the two cells. Instead of entering a value into the target cell by 
typing or pasting, you create a formula that identifies the source from which Excel will 
derive the target cell’s value and updates the value when it changes in the source cell.

To create a link between cells, open both the workbook that contains the cell from which 
you want to pull the value and the workbook with the target cell. Then click the target 
cell and type an equal sign, signifying that you want to create a formula. After you type 
the equal sign, activate the workbook with the cell from which you want to derive the 
value, click that cell, and then press the Enter key.

When you switch back to the workbook with the target cell, you see that Excel has filled 
in the formula with a reference to the cell you clicked.

For example, the reference =’[FleetOperatingCosts.xlsx]Truck Fuel’!$C$15 gives three 
pieces of information: the workbook, the worksheet, and the cell you clicked in the 
worksheet. The first element of the reference, the name of the workbook, is enclosed 
in square brackets; the end of the second element (the worksheet) is marked with an 
exclamation point; and the third element, the cell reference, has a dollar sign before 
both the row and the column identifier. The single quotes around the workbook name 
and worksheet name are there to account for the space in the Truck Fuel worksheet’s 
name. This type of reference is known as a 3-D reference, reflecting the three dimen-
sions (workbook, worksheet, and cell range) that you need to point to a group of cells 
in another workbook.



Tip  For references to cells in the same workbook, the workbook information is omitted. 
Likewise, references to cells in the same worksheet don’t use a worksheet identifier.

You can also link to cells in an Excel table. Such links include the workbook name, work-
sheet name, name of the Excel table, and row and column references of the cell to which 
you’ve linked. Creating a link to the Cost column’s cell in a table’s Totals row, for example, 
results in a reference such as =’FleetOperatingCosts.xlsx’!Truck Maintenance[[#Totals],[Cost]]. 

Important  Hiding or displaying a table’s Totals row affects any links to a cell in that row. 
Hiding the Totals row causes references to that row to display a #REF! error message.

Whenever you open a workbook containing a link to another document, Excel tries to 
update the information in linked cells. If the program can’t find the source, as would 
happen if a workbook or worksheet is deleted or renamed, an alert box appears to 
indicate that there is a broken link. At that point, you can click the Update button 
and then the Edit Links button to open the Edit Links dialog box and find which link 
is broken. After you identify the broken link, you can close the Edit Links dialog box, 
click the cell containing the broken link, and create a new link to the desired data.

If you type a link and you make an error, a #REF! error message appears in the cell that 
contains the link. To fix the link, click the cell, delete its contents, and then either retype 
the link or create it with the point-and-click method described earlier in this section.

Tip  Excel tracks workbook changes, such as when you change a workbook’s name, very well. 
Unless you delete a worksheet or workbook, or move a workbook to a new folder, odds are 
good that Excel can update your link references automatically to reflect the change.

In this exercise, you’ll create a link to another workbook, make the link’s reference invalid, 
use the Edit Links dialog box to break the link, and then re-create the link correctly.

SET UP  You need the OperatingExpenseDashboard_start and FleetOperatingCosts_start 
workbooks located in your Chapter07 practice file folder to complete this exercise. 
Open the OperatingExpenseDashboard_start and FleetOperatingCosts_start workbooks, 
and save them as OperatingExpenseDashboard and FleetOperatingCosts, respectively. 
Then follow the steps.

	 1.	 In the OperatingExpenseDashboard workbook, in cell I6, type =, but do not 
press Enter.

	 2.	 On the View tab, in the Window group, click Switch Windows and then, in the 
list, click FleetOperatingCosts.

The FleetOperatingCosts workbook is displayed.
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	 3.	 If necessary, click the Plane Repair sheet tab to display the Plane Repair worksheet, 
and then click cell C15.

Excel sets the cell’s formula to =’[FleetOperatingCosts.xlsx]Plane Repair’!$C$15.

	 4.	 Press Enter.

Excel displays the OperatingExpenseDashboard workbook; the value $2,410,871 
appears in cell I6.

Tip  Yes, cell C15 on the Plane Repair worksheet contains the wrong total for the 
Airplane Fuel category; that’s why you replace it later in this exercise.

	 5.	 In the Switch Windows list, click FleetOperatingCosts.

The FleetOperatingCosts workbook is displayed.

	 6.	 Right-click the Plane Repair sheet tab, and then click Delete. In the message box 
that appears, click Delete to confirm that you want to delete the worksheet.

Excel deletes the Plane Repair worksheet.

	 7.	 In the Switch Windows list, click OperatingExpenseDashboard.

The OperatingExpenseDashboard workbook is displayed, showing a #REF! error in 
cell I6.



	 8.	 On the Data tab, in the Connections group, click Edit Links.

The Edit Links dialog box opens.

	 9.	 Click Break Link.

Excel displays a warning box asking if you’re sure you want to break the link.

	 10.	 Click Break Links.

The warning box closes, and Excel removes the link from the workbook.

	 11.	 Click Close.

The Edit Links dialog box closes.
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	 12.	 In cell I6, type =, but do not press Enter.

	 13.	 In the Switch Windows list, click FleetOperatingCosts.

The FleetOperatingCosts workbook is displayed.

	 14.	 Click the Plane Fuel sheet tab.

The Plane Fuel worksheet is displayed.

	 15.	 Click cell C15, and then press Enter.

Excel displays the OperatingExpenseDashboard workbook with the value 
$52,466,303 in cell I6.

CLEAN UP  Save the OperatingExpenseDashboard and FleetOperatingCosts 
workbooks, and then close them.

Consolidating Multiple Sets of Data into a Single 
Workbook

When you create a series of worksheets that contain similar data, perhaps by using  
a template, you build a consistent set of workbooks in which data is stored in a pre-
dictable place. For example, consider a workbook template that uses cell C5 to record 
the number of calls received from 9:00 A.M. to 10:00 P.M. by the Northeast distribu-
tion center.



Using links to bring data from one worksheet to another gives you a great deal of power 
to combine data from several sources into a single resource. For example, you can create a 
worksheet that lists the total revenue just for certain months of a year, use links to draw 
the values from the worksheets in which the sales were recorded, and then create a for-
mula to perform calculations on the data. However, for large worksheets with hundreds 
of cells filled with data, creating links from every cell is a time-consuming process. Also, 
to calculate a sum or an average for the data, you would need to include links to cells in 
every workbook.

Fortunately, there is an easier way to combine data from multiple worksheets in a single 
worksheet. This process, called data consolidation, enables you to define ranges of cells 
from multiple worksheets and have Excel summarize the data. You define these ranges 
in the Consolidate dialog box.
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After you open the dialog box, you move to the worksheet that contains the first cell range 
you want to include in your summary. When you select the cells, the 3-D reference for 
the range appears in the Consolidate dialog box. Clicking Add stores the reference. You 
can then choose the other cell ranges that contain data you want to include in the sum-
mary, or you can remove a range from the calculation by clicking the range and then 
clicking Delete. 

Cells that are in the same relative position in the ranges have their contents summarized 
together. When you consolidate the ranges, the cell in the upper-left corner of one range 
is added to the cell in the upper-left corner of every other range, even if those ranges are in  
different areas of the worksheet. After you choose the ranges to be used in your sum-
mary, you can choose the calculation to perform on the data (sum, average, and so on). 
When you’re done selecting ranges to use in the calculation, click OK to have Excel sum-
marize the data on your target worksheet.

Important  You can define only one data consolidation summary per workbook.

In this exercise, you’ll define a data consolidation range consisting of ranges from two 
other workbooks. You’ll then add the contents of the ranges and show the results in a 
worksheet.

SET UP  You need the Consolidate_start, JanuaryCalls_start, and FebruaryCalls_start 
workbooks located in your Chapter07 practice file folder to complete this exercise. 
Open the Consolidate_start, JanuaryCalls_start, and FebruaryCalls_start workbooks, 
and save them as Consolidate, JanuaryCalls, and FebruaryCalls, respectively. Then 
follow the steps. 

	 1.	 In the Consolidate workbook, on the Data tab, in the Data Tools group, click 
Consolidate.

The Consolidate dialog box opens.

	 2.	 Click the Collapse Dialog button at the right edge of the Reference field.

The Consolidate dialog box contracts.



	 3.	 On the View tab, in the Window group, click Switch Windows and then, in the 
list, click JanuaryCalls.

The JanuaryCalls workbook is displayed.

	 4.	 Select the cell range C5:O13, and then click the Expand Dialog button.

The Consolidate dialog box is restored to its full size.

	 5.	 Click Add.

The range you selected appears in the All References pane.

	 6.	 Click the Collapse Dialog button at the right edge of the Reference field.

The Consolidate dialog box contracts.

	 7.	 In the Switch Windows list, click FebruaryCalls.

The FebruaryCalls workbook is displayed.

	 8.	 Select the cell range C5:O13, and then click the Expand Dialog button.

The Consolidate dialog box is restored to its full size.

	 9.	 Click Add.

The range ‘[FebruaryCalls.xlsx]February’!$C$5:$O$13 appears in the All References 
pane.
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	 10.	 Click OK.

Excel consolidates the JanuaryCalls and FebruaryCalls workbook data into the range 
C5:O13 in the Consolidate workbook. You didn’t change the SUM operation in the 
Function box, so the values in the Consolidate workbook are the sum of the other 
workbooks’ values.

CLEAN UP  Save the Consolidate, JanuaryCalls, and FebruaryCalls workbooks, and 
then close them.

Grouping Multiple Sets of Data
When you work with Excel for a while, you’ll find that you often open a number of the 
same workbooks at the same time. For instance, Lori Penor, the chief operating officer of 
Consolidated Messenger, might always pull up a workbook that tracks labor costs at the 
same time she opens the package volume summary workbook. She can open the work-
books individually through the Open dialog box, but she can also group the files so that 
she has the option of opening them all simultaneously.

If you want to open a set of files simultaneously, you can define them as part of a work-
space, which uses one file name to reference several workbooks. To define a workspace, 
you open the files you want to include and then open the Save Workspace dialog box.



Clicking Save in the Save Workspace dialog box saves references to all the Excel files that 
are currently open. Whenever you open the workspace you create, all the files that were 
open when you defined the workspace are displayed. Including a file in a workspace 
doesn’t remove it from general circulation; you can still open it by itself.

In this exercise, you’ll save a workspace that consists of two workbooks, close the included 
files, and then test the workspace by opening it from the Open dialog box.

SET UP  You need the OperatingExpenseDashboard and FleetOperatingCosts 
workbooks you created in the second exercise in this chapter to complete this  
exercise. If you did not complete that exercise, you should do so now. Open the  
OperatingExpenseDashboard and FleetOperatingCosts workbooks. Then follow  
the steps. 

	 1.	 In either workbook, on the View tab, in the Window group, click Save 
Workspace.

The Save Workspace dialog box opens.
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	 2.	 In the File name field, type Expenses.

	 3.	 Click Save.

Excel saves your workspace and closes the Save Workspace dialog box.

	 4.	 Click the File tab, and then click Close.

Excel closes the active workbook.

	 5.	 Click the File tab, and then click Close.

Excel closes the second workbook.

	 6.	 Click the File tab and (if necessary), click Recent. In the Recent Workbooks 
list, click Expenses.xlw.

Excel opens the OperatingExpenseDashboard and FleetOperatingCosts 
workbooks.

CLEAN UP  Close the OperatingExpenseDashboard and FleetOperatingCosts 
workbooks. If you are not continuing directly to the next chapter, exit Excel.



Key Points
●	 If you create a lot of workbooks with the same layout and design, saving a workbook 

with the common elements (and no data) will save you time when you create similar 
workbooks in the future.

●	 You can use data in other worksheets or workbooks in your formulas. You make the 
link by clicking the cell, which creates a 3-D reference to that cell.

●	 When you create a link to a cell in a table’s Totals row, hiding the Totals row causes 
Excel to display a #REF! error in the cell where you created the link.

●	 If you always work on a group of workbooks at the same time, create a workspace 
so that you can open them all at once.
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